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New Project

Test Case #:

01.01

Functionality:
Create New Root

Environments:
No projects are currently open.

Procdeure:

1. Select ‘New Project…’ from the ‘File’ menu

2. Click on ‘Create New Root’

3. Name your root file whatever you wish by typing the name in File Name field.  

4. Select the ‘File Type’ for your Resource Bundles

5. Click ‘OK’ to create the Project with the Root

Expected Outcome:

The name you give the Project File will be used as the base name for all of the Resource Bundle Files including the root.  The Project Window will now pop up in the Main Window with only an empty Root Resource Bundle.

Test Case #:

01.02

Functionality:
Canceling a new project from existing root.

Environment:
A project is currently open.

Procdeure:

1. Select ‘New Project…’ from the ‘File’ menu

2. A ‘Close Project’ dialogue box will pop up asking if you wish to save the current project.  Click on ‘No’.

3. Click on ‘Use Existing Root’

4. Click on ‘Cancel’.

Expected Outcome: 

When finished, the existing project will be closed.  The Main Window will be empty.  The New Project will not be created.

Test Case #:

01.03

Functionality:
Create New Project from Existing Root
Environment:
A project is currently open and has been modified.

Procdeure:

1. Select ‘New Project…’ from the ‘File’ menu

2. A ‘Close Project’ dialogue box will pop up asking if you wish to save the current project.  Click on ‘Yes’.

3. Click on ‘Use Existing Root’

4. Find the Root you wish to import and click on ‘OK’

5. A dialogue will appear asking to enter the root’s file name.  Enter your desired name for the root and click ‘OK’.

Expected Outcome: 

Upon saving, that project will then be closed and any modifications will be saved.  The closed project must be opened to verify saved changes.  The Project Window will now pop up in the Main Window with the Root Resource Bundle.

Test Case #:

01.04

Functionality:
Canceling a New Project from a Close Dialog
Environment:
A project is currently open.

Procdeure:

1. Select ‘New Project…’ from the ‘File’ menu.

2. A ‘Close Project’ dialogue box will pop up asking if you wish to save the current project.  Click on ‘Cancel’.

Expected Outcome: 

The Main Window will remain unchanged.

Test Case #:

01.05

Functionality:
Canceling a New Project
Environment:
No project is currently open.  A Loose File is open

Procdeure:

1. Select ‘New Project…’ from the ‘File’ menu.

2. Click on ‘Cancel’.

Expected Outcome: 

The Main Window will remain unchanged.

Loading Existing Projects

Test Case #:

02.01

Functionality:
Loading a Project
Environment:
No project is currently open.  The project file and all associated Resource Bundles are intact.

Procdeure:

1. Select ‘Open Project’ from the’ File’ menu

2. Find the Project File for the Project that you wish to load. (Remember that Project files have the extension RBP)

3. Click Open to load it into the Resource Editor

Expected Outcome: 

The Main Window will display the Project in the Project Window.

Test Case #:

02.02

Functionality:
Loading a Project with a missing root.
Environment:
No project is currently open.  The project file refers to a root that will not be provided.

Procdeure:

1. Select ‘Open Project’ from the’ File’ menu

2. Find the Project File for the Project that you wish to load. (Remember that Project files have the extension RBP)

3. Click Open to load it into the Resource Editor

4. Expand the Project Tree and double-click on a child bundle to open an editor window.

5. Select ‘New Bundle’ from the ‘Project’ menu to attempt to add a bundle.

6. Select ‘Add Key’ from the ‘Project’ menu to attempt to add a key.

7. Select ‘Delete Key’ from the ‘Project’ menu to attempt to delete a key.

8. Select ‘Rename Key’ from the ‘Project’ menu to attempt to rename a key.

Expected Outcome: 

The Main Window will display the Project in the Project Window at Step 3.  A ‘Root Not Found’ error message will be displayed.  The Editor Window for the child bundle will display error messages for the parent value.  Steps 5-8 should are not allowed and will produce error messages.

Test Case #:

02.03

Functionality:
Loading a Project with a missing resource.
Environment:
No project is currently open.  The project file refers to a root that will not be provided.

Procdeure:

1. Select ‘Open Project’ from the’ File’ menu

2. Find the Project File for the Project that you wish to load. (Remember that Project files have the extension RBP)

3. Click Open to load it into the Resource Editor

4. Expand the Project Tree and double-click on a child bundle of the missing resource to open an editor window.

5. Select ‘New Bundle’ from the ‘Project’ menu to attempt to add a bundle.

6. Select ‘Add Key’ from the ‘Project’ menu to attempt to add a key.

7. Select ‘Delete Key’ from the ‘Project’ menu to attempt to delete a key.

8. Select ‘Rename Key’ from the ‘Project’ menu to attempt to rename a key.

Expected Outcome:
The Main Window will display the Project in the Project Window at Step 3.  A ‘Resource Not Found’ error message will be displayed.  The Editor Window for the child bundle will display error messages for the parent value.  Steps 5-8 are not allowed and will produce error messages.

Loading a Loose File

Test Case #:

03

Functionality:
Loading a Loose File
Environment:
A project is currently open. 

Procdeure:

1. Select ‘Open’ from the ‘File’ menu

2. Find the Loose File that you wish to load

3. Click Open to load it

Expected Outcome:
The Main Window will display an Easy Tab and Editor Window for the Loose File.  The Editor Window for the Loose File will not display the parent value.  

Saving a Project

Test Case #:

04.01

Functionality:
Saving a Project
Environment:
A project is currently open with modifications made.  A Loose File is open.

Procdeure:

1. Click on the Project Window or any Editor Window of a Child in the Project to bring it into focus.

2. Select ‘Save’ from the ‘File’ menu.

Expected Outcome: 

The project will be saved, with the modifications.  The Project must be closed and reopened to verify the modifications.

Test Case #:

04.02.x

Special Case:

Repeat for each File Type supported
Functionality:
Saving a Project with a New Name/Type
Environment:
A project is currently open.  No Loose Files are open.

Procdeure:

1. Click on the Project Window or any Editor Window of a Child in the Project to bring it into focus.

2. Select ‘Save Project As…’ from the ‘File’ menu.

3. Type in a new name for the Project.

4. Select a new File Type for the Resource Bundles to be saved as.

5. Click ‘Save’.

Expected Outcome: 

The project will be saved to the new filename, with the modifications.  The New Project must be closed and reopened to verify the modifications.  The previous project must be reopened to verify that no changes were made.

Test Case #:

04.03.a

Functionality:
Overwrite checking for saving a Project with a New Name
Environment:
A project is currently open.  No Loose Files are open.  There exists a project in the working directory with the same name and File Type that will be specified in the ‘Save’ Dialog

Procdeure:

1. Click on the Project Window or any Editor Window of a Child in the Project to bring it into focus.

2. Select ‘Save Project As…’ from the ‘File’ menu.

3. Type in an existing name for the Project.

4. Select the corresponding File Type for the Resource Bundles to be saved as.

5. Click ‘Save’.

6. A ‘File Already Exists’ error message will appear.  Click ‘No’ to cancel Save process.

Expected Outcome: 

The project will not be saved.  The current project must be closed and the existing project opened to verify that it was not overwritten.

Test Case #:

04.03.b

Functionality:
Overwrite checking for saving a Project with a Same Name
Environment:
A project is currently open.  No Loose Files are open.  There exists a project in the working directory with the same name and File Type that will be specified in the ‘Save’ Dialog

Procdeure:

1. Click on the Project Window or any Editor Window of a Child in the Project to bring it into focus.

2. Select ‘Save Project As…’ from the ‘File’ menu.

3. Keep the same name for the Project.

4. Keep the same File Type for the Resource Bundles to be saved as.

5. Click ‘Save’.

6. A ‘File Already Exists’ error message will appear.  Click ‘Yes’ to Overwrite.

Expected Outcome: 

The project will be saved, with the modifications.  The Project must be closed and reopened to verify the modifications.

Saving a Loose File

Test Case #:

05

Functionality:
Saving a Loose File
Environment:
A Loose File is currently open with modifications made.  A project is open.

Procdeure:

1. Make sure that the Loose File you wish to save is in focus (click on it’s editor window to put it in focus)

2. Select ‘Save’ from the ‘File’ menu

3. File will automatically be saved.

Expected Outcome: 

The Loose File will be saved, with the modifications.  The Loose File must be closed and reopened to verify the modifications.

Add a New Bundle to the Project

Test Case #:

06.01.x

Special Case:

Do once for Language, Country and Variant

Functionality:
Creating a New Bundle
Environment:
A Project is open with at least one (1) child bundle.

Procdeure:

1. Select ‘New Bundle’ from the ‘Project’ menu

2. Select the Language, then select a Country and/or Variant if desired, such that the Bundle does not already exist, and its parent bundle does exist.

3. Click ‘OK’

Expected Outcome: 

The New Bundle will automatically be inserted into the Project Window under the appropriate parent.  The new bundle will automatically use the base name of the Project File with the appropriate language extensions the next time the Project is saved.

Test Case #:

06.02

Functionality:
Creating a New Bundle that already exists
Environment:
A Project is open with at least one (1) existing Language, Country and Variant bundle in place.

Procdeure:

1. Select ‘New Bundle’ from the ‘Project’ menu

2. Select the Language, then select a Country and Variant corresponding to the bundles that are already in place.

3. Click ‘OK’

Expected Outcome: 

An Error message will be displayed.  The new bundle will not be inserted into the Project.

Test Case #:

06.03

Functionality:
Creating a New Bundle without a parent
Environment:
A Project is open with no child bundles.

Procdeure:

1. Select ‘New Bundle’ from the ‘Project’ menu

2. Select the Language, AND select a Country.

3. Click ‘OK’

Expected Outcome: 

An Error message will be displayed.  The new bundle will not be inserted into the Project.

Importing an Existing Bundle into the Project

Test Case #:

07.01.x

Special Case:

Do once for Language, Country and Variant

Functionality:
Importing an Existing Bundle into the Project
Environment:
A Project is open with at least one (1) child bundle.

Procdeure:

1. Select ‘Import Bundle’ from the ‘Project’ menu

2. Find the existing file for the Resource Bundle you wish to add and click ‘Add’

3. Select the language and, if desired, the country and variant that the child is in, such that the Bundle does not already exist, and its parent bundle does exist.

4. Click ‘Open’.

Expected Outcome: 

The New Bundle will automatically be inserted into the Project Window under the appropriate parent.  The new child will automatically use the base name of the Project File with the appropriate language extensions the next time the Project is saved.

Test Case #:

07.02

Functionality:
Importing an Existing Bundle into the Project with New Keys
Environment:
A Project is open with at least one (1) child bundle.

Procdeure:

1. Select ‘Import Bundle’ from the ‘Project’ menu

2. Find the existing file for the Resource Bundle you wish to add and click ‘Add’

3. Select the language and, if desired, the country and variant that the child is in, such that the Bundle does not already exist, and its parent bundle does exist.

4. Click ‘Open’.

Expected Outcome: 

The New Bundle will automatically be inserted into the Project Window under the appropriate parent.  The new child will automatically use the base name of the Project File with the appropriate language extensions the next time the Project is saved.

Test Case #:

07.03

Functionality:
Importing an Existing Bundle that already exists in the Project
Environment:
A Project is open with at least one (1) existing Language, Country and Variant bundle in place.

Procdeure:

1. Select ‘Import Bundle’ from the ‘Project’ menu

2. Find the existing file for the Resource Bundle you wish to add and click ‘Add’

3. Select the Language, then select a Country and Variant corresponding to the bundles that are already in place.

4. Click ‘Open’.

Expected Outcome: 

An Error message will be displayed.  The new bundle will not be inserted into the Project.

Test Case #:

07.04

Functionality:
Importing an Existing Bundle without a parent
Environment:
A Project is open with no child bundles.

Procdeure:

1. Select ‘Import Bundle’ from the ‘Project’ menu

2. Find the existing file for the Resource Bundle you wish to add and click ‘Add’

3. Select the Language, AND select a Country.

4. Click ‘Open’.

Expected Outcome: 

An Error message will be displayed.  The new bundle will not be inserted into the Project.

Removing a Bundle from the Project

Test Case #:

08.01.x

Special Case:

Do once for Language, Country and Variant

Functionality:
Removing a Bundle from the Project
Environment:
A Project is open with at least one (1) existing Language, Country and Variant bundle in place.

Procdeure:

1. Select the Language, then select a Country and Variant corresponding to the bundle in the Project Window that needs to be removed from the Project

2. Select ‘Remove Bundle’ from the ‘Project’ menu

3. A warning message will pop up.  Click Yes

Expected Outcome: 

The Bundle will automatically be removed from the Project Window.  Any Child Bundles of that Bundle will also be removed.

Test Case #:

08.02

Functionality:
Cancel Removing a Bundle from the Project
Environment:
A Project is open with at least one (1) existing bundle.

Procdeure:

1. Select the Language, then select a Country and Variant corresponding to the bundle in the Project Window that needs to be removed from the Project

2. Select ‘Remove Bundle’ from the ‘Project’ menu

3. A warning message will pop up.  Click No

Expected Outcome: 

The Bundle will not be removed from the Project Window.

Closing Files

Test Case #:

09.01

Functionality:
Closing a Project
Environment:
A project is currently open.  A Loose File is open.

Procdeure:

1. Make sure that any file in a project has focus.

2. Select ‘Close’ from the ‘File’ menu

3. A message will pop up asking if you wish to save the Project.  Click ‘Yes’ to save it.

Expected Outcome: 

The Project Window, Editor Windows and Easy Tabs for the project are no longer displayed.  The Project must be reopened to confirm the saving of modifications.

Test Case #:

09.02

Functionality:
Closing a Loose File
Environment:
A loose file is currently open.  A project is open.

Procdeure:

1. Make sure that the Loose file you wish to close has focus.

2. Select ‘Close’ from the ‘File’ menu

3. A message will pop up asking if you wish to save the Loose File.  Click ‘No’ to close without saving.

Expected Outcome: 

The Editor Window and Easy Tab for the Loose File are no longer displayed.  The Loose File must be reopened to confirm that modifications were not saved.

Test Case #:

09.03

Functionality:
Canceling a Close
Environment:
A project is currently open.  A Loose File is open.

Procdeure:

1. Make sure that any file in a project has focus.

2. Select ‘Close’ from the ‘File’ menu

3. Click Cancel.

Expected Outcome: 

No changes are made.

The Toolbar

Test Case #:

10.01.x

Special Case:

Repeat for each Toolbar button

Functionality:
Main Window Toolbar Shortcuts

Environment:
A Project and Editor Window is open.  A key in one of the resource bundles is selected.

Procdeure:

1. Click on the Toolbar button

Expected Outcome: 

The dialog for the corresponding functionality is displayed.  (For Save, no dialog is displayed.  The Project must be closed and reopened to confirm modifications.)

Test Case #:

10.02.x

Special Case:

Repeat for each Toolbar button

Functionality:
Editor Window Toolbar Shortcuts

Environment:
A Project and Editor Window is open.  A key in one of the resource bundles is selected.

Procdeure:

1. Click on the Editor Window Toolbar button

Expected Outcome: 

The dialog for the corresponding functionality is displayed.

Menu

Test Case #:

11.01

Special Case:

Repeat for each menu on the menu bar

Functionality:
Menu accessibility
Environment:
A project is currently open.  A Loose File is open.  The Project is in focus.

Procdeure:

1. Click on the appropriate menu on the menu bar.

2. Walk down the pull down menu, highlighting each menu item

Expected Outcome: 

All menu items should be able to be highlighted

Test Case #:

11.02

Special Case:

Repeat for each menu on the menu bar

Functionality:
Menu accessibility
Environment:
A project is currently open.  A Loose File is open.  The Loose File is in focus.

Procdeure:

1. Click on the appropriate menu on the menu bar.

2. Walk down the pull down menu, highlighting each menu item

Expected Outcome: 

All menu items should be able to be highlighted, except ‘Add Key’, ‘Rename Key’ and ‘Delete Key’

Test Case #:

11.03

Special Case:

Repeat for each menu on the menu bar

Functionality:
Menu accessibility
Environment:
A project is currently open.  The root bundle is selected in the Project Window.

Procdeure:

1. Click on the appropriate menu on the menu bar.

2. Walk down the pull down menu, highlighting each menu item

Expected Outcome: 

All menu items should be able to be highlighted, except ‘Remove Bundle’

The Project Window

Test Case #:

12.01

Functionality:
Tree Nodes
Environment:
A project is currently open, with at least one (1) child bundle.  

Procdeure:

1. Click on a Closed Node icon.

2. Click on a Opened Node icon.

Expected Outcome: 

After Step 1, the Closed Node icon becomes an Opened Node icon.  The Project tree is expanded to show the child bundles of that node.  After Step 2, the Opened Node icon becomes a Closed Node icon.  The Project tree is compressed to hide the child bundles of that node.

Test Case #:

12.02

Functionality:
Opening Editor Windows
Environment:
A project is currently open, and expanded

Procdeure:

1. Double Click on a Resource Bundle.

Expected Outcome: 

An Editor Window appears displaying the values for that Bundle.  An Easy Tab is added for that Editor Window.

Test Case #:

12.03

Functionality:
Minimizing and Restoring
Environment:
A project is currently open.

Procdeure:

1. Click on the Minimize Icon on the Project Window

2. Click on the Project Title-bar.

Expected Outcome: 

After Step 1, the Project Window is minimized to a title bar in the bottom left of the Main Window.  After Step 2, the project Window is restored to its previous position.

Test Case #:

12.04

Functionality:
Moving
Environment:
A project is currently open, and expanded

Procdeure:

1. Click on the Project Title-bar without releasing.

2. Move the mouse and release the left mouse button.

Expected Outcome: 

The Project Window has been moved relative to the mouse movements.

Editor Window

Test Case #:

13.01

Functionality:
Minimizing and Restoring
Environment:
An Editor Window is currently open.

Procdeure:

1. Click on the Minimize Icon on the Editor Window

2. Click on the Editor Window Title-bar.

Expected Outcome: 

After Step 1, the Editor Window is minimized to a title bar in the bottom left of the Main Window.  After Step 2, the Editor Window is restored to its previous position.

Test Case #:

13.02

Functionality:
Maximizing and Closing
Environment:
An Editor Window is currently open.

Procdeure:

1. Click on the Maximize Icon on the Editor Window

2. Click on the Close Icon on the Editor Window

Expected Outcome: 

After Step 1, The Editor Window fills the Main Window.  After Step 2, The Editor Window is removed the Main Window and its Easy tab is no longer displayed.

Test Case #:

13.03

Functionality:
Moving
Environment:
An Editor Window is currently open

Procdeure:

1. Click on the Editor Window Title-bar without releasing.

2. Move the mouse and release the left mouse button.

Expected Outcome: 

The Editor Window has been moved relative to the mouse movements.

Test Case #:

13.04

Functionality:
Table Accessibility
Environment:
An Editor Window is currently open, with at least one (1) key.

Procdeure:

1. Click on a row in the table

2. Double-click on a comment in the table

Expected Outcome: 

After Step 1, the row in the table is highlighted (Default color: Blue).  After Step 2, the row in the table is highlighted (Default color: Blue), and the comment field is selected (Default color: White with Blue Border) and displays a cursor.

Test Case #:

13.05.x

Special Case:

Repeat for each data type

Functionality:
Value Accessibility
Environment:
An Editor Window is currently open, with at least one (1) key of type X.

Procdeure:

1. Double-click on a value field of the type X in the table.

Expected Outcome: 

For Simple Data types, the value field is selected (Default color: White with Blue Border) and displays a cursor.  For Complex Data types, the corresponding dialog is displayed.

Add Key

Test Case #:

14.01.x

Special Case:

Repeat for each data type

Functionality:
Create a New Key
Environment:
A Project is currently open, with at least two (2) Language / Country / Variant Bundles in place.

Procdeure:

1. Select ‘Add Key’ from the ‘Edit’ menu

2. Type in the name of the new key and select the data type for the new key.

3. Click on ‘OK’

Expected Outcome: 

The key will be inserted into each resource bundle in the project.  Editor Windows must be opened to confirm the addition.

Test Case #:

14.02

Functionality:
Cancel a Create a New Key
Environment:
A Project is currently open.

Procdeure:

1. Right click on an Editor Window to bring up a Pop-Up menu, then select ‘Add Key’

2. Click on ‘Cancel’.

Expected Outcome: 

No changes will be made.

Test Case #:

14.03

Functionality:
Create a New Key with Existing Key Name
Environment:
A Project is currently open, with at least one (1) key instantiated.

Procdeure:

1. Click the ‘Add Key’ Icon on the Toolbar.

2. Type in the name of the existing key and select the data type for the existing key.

3. Click on ‘OK’

Expected Outcome: 

An Error message will be displayed.  No changes will be made.

Delete Key

Test Case #:

15.01

Functionality:
Delete a Key
Environment:
A Project is currently open, with at least two (2) Language / Country / Variant Bundles in place and at least one (1) key instantiated.

Procdeure:

1. Select a Key in the Editor Window

2. Select ‘Delete Key’ from the ‘Edit’ menu

3. Click on ‘OK’

Expected Outcome: 

The key will be removed from each resource bundle in the project.  Editor Windows must be opened to confirm the addition.

Test Case #:

15.02

Functionality:
Cancel a Delete Key
Environment:
A Project is currently open, with at least one (1) key instantiated.

Procdeure:

1. Select a Key in the Editor Window 

2. Right click on the Editor Window to bring up a Pop-Up menu, then select ‘Delete Key’

3. Click on ‘Cancel’.

Expected Outcome: 

No changes will be made.

Rename Key

Test Case #:

16.x

Not Yet Implemented

Modify Value

Test Case #:

17.01

Functionality:
Edit Primitive Data Types (String, Integer, Binary Value, Object Value)
Environment:
A project is currently open, with at least one (1) child bundle and at least one (1) Entry.

Procdeure:

1. Select a bundle that has a child bundle.

2. Double click on the Value field in the Editor Window of the Entry you wish to edit.

3. Input the desired Value.

Expected Outcome: 

After Step 2, the row in the table is highlighted (Default color: Blue), and the value field is selected (Default color: White with Blue Border) and displays a cursor.  After Step 3, the new value is displayed in the table.  The new value is also displayed as the Parent Value in the child bundle’s Editor Window.

Test Case #:

17.02.a

Functionality:
Edit Binary Path
Environment:
A project is currently open, with at least one (1) Entry of the type Binary Path.  An entry of the type Binary Path is selected.

Procdeure:

1. Bring up the BinaryPath Dialog box by selecting ‘Edit Value’ from the ‘Edit’ menu.

2. The BinaryPath Dialog box looks much like the normal Load File Dialog box.  Select the file you wish to point to.

3. Click ‘Open’.

Expected Outcome: 

The path and filename of the file specified in Step 2 is displayed in the Value column of the Entry.

Test Case #:

17.02.b

Functionality:
Edit Binary Path with missing file
Environment:
A project is currently open, with at least one (1) Entry of the type Binary Path.  An entry of the type Binary Path is selected.

Procdeure:

1. Bring up the BinaryPath Dialog box by selecting ‘Edit Value’ from the ‘Edit’ menu.

2. Type in the path and file name of a nonexistent file in the File Name box.

3. Click ‘Open’.

Expected Outcome: 

A warning message will be displayed.  The path and filename of the file specified in Step 2 is displayed in the Value column of the Entry.

Test Case #:

17.03

Functionality:
Edit Array data types (String Array, Integer Array)
Environment:
A project is currently open, with at least one (1) Entry of the type Array.

Procdeure:

Expected Outcome: 

Test Case #:

17.04

Functionality:
Edit Message
Environment:
A project is currently open, with at least one (1) child bundle and at least one (1) Entry of the type Message.

Procdeure:

Expected Outcome: 

Test Case #:

17.05

Functionality:
Edit Tagged Arrays
Environment:
A project is currently open, with at least one (1) child bundle and at least one (1) Entry of the type Tagged Array.

Procdeure:

Expected Outcome: 

Modify Comment

Test Case #:

18

Functionality:
Edit Comment
Environment:
An Editor Window is currently open, with at least one (1) key.

Procdeure:

1. Double click on the Comments field in the Editor Window of the Entry you wish to edit.

2. Input the desired comment.

Expected Outcome: 

After Step 1, the row in the table is highlighted (Default color: Blue), and the comment field is selected (Default color: White with Blue Border) and displays a cursor.  After Step 2, the new comment is displayed in the table.  

Undo / Redo

Test Case #:

19

Not Yet Implemented 

Cut / Copy / Paste

Test Case #:

20

Not Yet Implemented
View / Hide Fields

Test Case #:

21.x

Not Yet Implemented
Easy Tabs

Test Case #:

22

Functionality:
Accessibility
Environment:
A Project is currently open with at least one (1) bundle open.  A Loose File is open.

Procdeure:

1. Click on the Easy Tab for the Project Window.

2. Click on the Easy Tab for the Project’s resource bundle.

3. Click on the Easy Tab for the Loose File.

Expected Outcome: 

The Corresponding Window is brought into focus after each Step is completed.

Preferences

Test Case #:

23.x

Not Yet Implemented

Help

Test Case #:

24

Functionality:
Help Topics
Environment:
A Project is currently open.

Procdeure:

1. Click on ‘Help Topics’ in the ‘Help’ Menu

Expected Outcome: 

A Help dialog will be displayed.

